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 ❖ It can be used as a mass production image producer to develop diherent models.
 ❖ ke advanced scripting interface allows everything from the simplest task to the 

most complex image manipulation procedures to be easily scripted.
 ❖ It can convert and save jles to many jle formats such as gif, jpeg, tih.etc
 ❖ It can load and save animations in a convenient frame as layer format.
 ❖ Virtually unlimited images can be opened at one time.
 ❖ GIMP works with numerous operating systems including Linux, Mac OS and 

Microsoi Windows.

2. TOOL BOX
ke Basic tools were learnt in Class IX. Here we would learn some advanced tools. 

2.1 Move Tool [M] 
ke Move Tool is used to move 
layers, selections, paths or  
guides of both the objects and  
the text.

2.2 Align Tool [Q] 
ke Align tool is useful to align  
the image layers with various image 
objects. 

2.3 Scale Tool [Shift + T] 
ke Scale Tool is used to scale layers, 
selections or paths (the Object).

2.4 Shear Tool [Shift + S] 
Shear tool is used to shii one selected 
part of an image, a layer, a selection 
or a path to a direction and the other 
part to the opposite direction. For 
instance, a horizontal shearing will 
shii the upper part to the right and 
the lower part to the lei. 

Rectangle Select tool Oval select tool

Foreground select tool Paths tool

Alignment too Crop tool

Flip tool Cage transform

Paintbrush tool Eraser tool

Perspective tool Blur/sharpen tool

Lasso too Fuzzy select tool tool

Color picker tool Zoom tool

Rotate tool Scale tool

Text tool Bucket jll tool

Airbrush tool Ink tool

Smudge tool Dodge/Burn tool

Select by color Scissors tool

Measure too Move tool

Shear tool Rectangle Select tool

Blend tool Pencil tool

Clone tool Heal tool

Foreground color Background color
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2.5 Perspective Tool 
ke Perspective Tool is used to view the images in diherent dimensions, of the active 
layer content. 

2.6 Flip an Image 
In a photo, if the face of a person is in the lei side direction, this tools changes the direction 
of the face to the right side.  It creates the mirror image of the photo. 

2.7 Rotate an Image 
kis tool is used to rotate an image in diherent directions i.e. from horizontal to vertical 
and vice versa.

2.8 Blend Tool [L]  
kis tool is used to jll the selected area with a gradient blend of the foreground and 
background colours by default. kese colours can be modijed to change the colour of 
the gradient.

2.9 Blur/Sharpen Tool [Shift +U] 
kis tool is used to blur or sharpen the image using the current brush. Note that in 
“Sharpen” mode, the tool increases the contrast where the brush is applied.

2.10 Smudge Tool [S] 
ke Smudge tool uses the current brush to smudge colours on the active layer or the 
selection. It takes the colour and uses it to mix it with the next colour it meets.

2.11 Dodge/Burn Tool [Shift + D] 
ke Dodge tool uses the current brush to lighten the colors in your image.

ke Burn tool uses the current brush to darken the colors in your image. 

ke mode will determine which types of pixels are ahected.

2.12 Eraser Tool [Shift + E] 
Eraser Tool works similar to a classic eraser. Simply select the tool and drag on the canvas 
to erase things.
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2.13 Pencil tool [N] 
ke Pencil Tool is used as the same way that you would use a real pencil to draw. Simply 
select the tool and drag on the canvas to draw with the Pencil Tool.

2.14 Paintbrush tool [P] 
ke Paint Brush tool draws brush like strokes, as if you were painting. It lets you create 
special ehects. Unlike the Pencil Tool, the brush tool draws both a jll and outline. 

3.  STEPS TO USE THE TOOLS STATED ABOVE USED IN GIMP 
ARE AS FOLLOWS

3.1 Move Tool [M] 
ke Move Tool is used to move layers, selections, paths or guides. It works also on 
texts.

You can access the Move Tool in diherent ways:

From the image menu bar Tools → Transform Tools → Move

By clicking the tool icon: 

By using the keyboard shortcut M.

ke Move tool is automatically activated when you create a guide.

To use this tool simply click on the canvas and drag the selection to a desired location.

Note: Holding down the space bar changes the active tool to Move temporarily.

3.2 Move Tool Options
Normally, tool options are displayed in a window attached 
under the Toolbox as soon as you activate a tool. If they 
are not, you can access them from the image menu bar 
through 

Windows → Dock able Windows → Tool Options which 
opens the option window of the selected tool.

Selection
Layer

Path
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If Move is on “Layer” – 
Only the current Layer 
will be moved.

If Move is on “Selection” – 
ke selection’s outline will 
be moved.

If Move is on “Path” - ke 
mouse pointer turns to a 
small hand when it goes 
over a visible path. ken you can move this path by click-and-dragging it (it will be the 
active path while moving.

3.3 Align Tool 
ke Align tool is useful to align the image layers with various image objects. When this 
tool is selected, the mouse pointer turns to a small hand. By clicking on an element of 
a layer in the image, you choose the layer which will be moved (with Shii + click, you 
can choose several layers to be aligned), this focalised layer has small squares in corners. 
Various buttons in the dialog allow you to select how the layer will be moved. And you 
can select the image object (other layer, selection, path...) the selected layer will be aligned 
on. kis object is called target.

You can activate the Align tool in several ways:
From the image-menu, through: Tools → Transform Tools → 
Align, By clicking on the tool icon: in the toolbox, By using 
the Q keyboard shortcut.

3.4 Align Tool Options           
ke options of Align Tool become active when a layer 

is selected. When you click on one of these buttons, you align 
the selected layer with lei edge, horizontal middle, right edge, 
top edge, vertical middle, or bottom of the target. 

          

kese options seem to diher from the “Related to ” options only by the possibility to 
set an ohset. kis ohset is the distance which will separate the selected layer(s) from 

Selected part of the Image is moved
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the target once the alignment is performed. 
Distribute add this ohset to the lei edges, 
horizontal centres, right edges, top edges, 
vertical centres, or bottoms of targets.

3.5 Scale Tool [Shift + T] 
ke Scale Image command enlarges or reduces the physical size of the image by changing 
the number of pixels it contains. It changes the size of the contents of the image and resizes 
the canvas accordingly.

You can access this command from the image menubar through Image → Scale Image.

Step 1: Click on Image → Scale Image

Step 2: Set the width and height and click on scale

Image aier scaling

Images using diherent alignments

Image Layer Colors Tools Filte sr Windows Help

Duplicate

Mode

Transform

Can as Size...v

Fit Canvas to L yersa

Fit Canvas to Selection

Print Size...

Scale Image...

Crop to Selection

Autocrop Image

Zealous Crop

Merge Visible Layers...

Flatten Image

Aligh Visi le Layers...b

Guides

Configure G id...r

Image Pr pertieso Atl+Return

Ctrl+M

Ctrl+D
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3.6 Shear Tool [Shift + S] 
Shear tool is used to shii one part of an image, a layer, a selection or a path to a direction 
and the other part to the opposite direction. For instance, a horizontal shearing will shii 
the upper part to the right and the lower part to the lei. 

You can use the shear tool in several ways:
In the image-menu through: Tools → Transform Tools → Shear,

By clicking the tool icon:   in Toolbox,

Also by using the Shii+S key combination.

Before using Shear Tool Aier using Shear Tool

3.7 Perspective Tool
ke Perspective Tool is used to change the dimensions of the active layer content, of 
selection content or of a path. 

You can use the Perspective tool in diherent ways: 
By clicking the tool icon: in Toolbox, By using the Shii+P key combination.

Aier using Perspective
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3.8 Flip an Image 
When you need the person in the photo looking in the other direction, or you need to top 
of the image to be the bottom like developing the Mirror image. Right click on the image 
and follow the menus Tools → Transform Tools → Flip, or use the button on the toolbox.

Image before fipping Image aier fipping

3.9 Rotate an image  
kis tool helps you to revolves the layer, paths and 
selected portion in the image.

It helps to spin an image in diherent directions.

Steps to rotate an image are as follows:
Right click on the image, and follow the menus 
Image → Transforms → Rotate → 90 degrees (or 
270 depending on the orientation). 

Image before Rotating Image aier Rotating

Image Layer Colors Tools Filte sr Windows Help

color, 1 layer) 640×400 - GMP

Duplicate

Mode

Transform

Can as Size...v

Fit Canvas to L yersa

F t Canvas to Selectioni

Print Size...

Scale Image...

Crop to Selection...

Autocrop Image

Zealous Crop

Merge Visible ayers...L

Flatten Image

Align Visi le Layers...b

Guides

Configure G id...r

Image Pr pertieso

Ctrl+D

Ctrl+M

Alt+Return

Flip orizontallyH

Flip erticallyV

Rotate 90° lockwisec

Rotate 90° counter-clock isew

Rotate 80°1

Guillotine
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3.10 Blend Tool [L] 
ke Blend tool creates a new color by gradually mixing multiple colours. kis tool jlls the 
selected area with a gradient blend of the foreground and background colours. To make a 
blend, drag the cursor in the direction you want the gradient to go, and release the mouse 
button when you feel you have the right position and size of your blend. ke soiness of 
the blend depends on how far you drag the cursor. ke shorter the drag distance, the 
sharper it will be.

kere are diherent possibilities to activate the tool:
From the image-menu: Tools → Paint Tools → Blend.

By clicking the tool icon .

By clicking on the L keyboard shortcut.

Step 1: Select the foreground and 
background colour if you want to 
blend two colours otherwise it will 
take white & black colour as default. 

Step 2: Fill the colour using bucket 
tool

Step 3: Click on blend tool and select the area 
till where you want to have blend ehect.
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3.11 Blur/Sharpen Tool [Shift +U] 
Blur mode causes each pixel ahected by the brush to be blended with neighbouring pixels, 
thereby increasing the similarity of pixels inside the brushstroke area. 

Sharpen mode causes each pixel to become more diherent from its neighbours, it increases 
contrast inside the brushstroke area. 

kere are diherent possibilities to activate the tool:
From the image-menu: Tools → Paint tools → Blur/Sharpen.
ke Tool can also be selected by clicking the tool icon in the Toolbox.
By using the keyboard shortcut Shii+U.

Holding down the Ctrl key toggles between Blur and 
Sharpen modes; it reverses the setting shown in the 
Tool Options.

 1. Set convolve type to switch between blur\
sharpen.

 2. Set the rate

 3. Click on the canvas area and keep on dragging 
the brush until the desired result is obtained.

Blurring can be useful if some element of your image stands out too much, and you would 
like to soien it. If you want to blur a whole layer, or a large part of one, you will probably 
be better oh using one of the Blur Filters.

Before Blurring the image Aier Blurring the image
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In “Sharpen” mode, the tool works by increasing the contrast where the brush is applied. 
Over-application of the tool will produce noise.

Before Sharpening the image Aier Sharpening the image

3.12 Smudge Tool [S] 
ke Smudge tool uses the current brush to smudge colours on the active layer or a selection. 
It takes color in passing and uses it to mix it to the next colours it meets, on a distance 
you can set.

You can jnd the Smudge tool in various ways:
krough Tools → Paint Tools → Smudge. in the image menu, by clicking on the tool icon: 
in Toolbox, Or by pressing the S key on keyboard.

Using Ctrl with Shii, you can constrain the angle between two successive lines to vary 
by steps of 15°.

  Before smudging the image Aier smudging the image

3.13 Dodge/Burn Tool [Shift + D] 
ke Dodge tool uses the current brush to lighten the colours in your image. 
ke Burn tool uses the current brush to darken the colours in your image.
ke mode will determine which types of pixels are ahected.
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kere are diherent possibilities to activate the tool:
From the image-menu: Tools → Paint Tools → Dodge / Burn.

ke Tool can also be called by clicking the tool icon or by using the Shii+D keyboard 
shortcut.

  Before using the Dodge Tool

Before using the Burn Tool

Aier using the Dodge Tool

Aier using the Burn Tool

4. LAYERS
In GIMP terminology, each individual transparency is called a layer.Layer provides a 
variety of ehects that change the appearance of the image. It allows you to work with one 
element of an image without disturbing the others. Layers are the transparent sheets one 
on top of the other. You can see through transparent areas of a layer to the layers below.

A new image in Gimp has a single layer. You can add a number of additional layers to 
add diherent elements in an image.

4.1 Adding a new layer:
To create a new layer follow the steps:
Layer menu  select new layer.

Enter the information for a new layer; transparency is good for overlapping layers or 
necessary for deleting portions of an image. 
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Give the layer a name which will help you to identify it later, such as while changing the 
background. 

Aier all the information is set, click the OK button.

4.2 Renaming a Layer
To rename a layer aier it is created, highlight the layer, right click it and select edit layer 
attributes, then type in a new name.
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4.3 Deleting a Layer
To delete a layer, select the layer and press the bin like looking button at the bottom of 
layers tab.

4.4 Merging a Layer
To merge a layer, 

Step 1: Open both the images as layers.

Step 2: Right-click the layer and select merge down or merge 
visible option available in the drop-down menu. ke Merge down 
option merges the selected layer with the layer right below it, 
whereas the Merge visible option merges all the visible layers.
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Step 3: Resultant image, aier merging the two 
layers.

4.5 Scaling a layer
ke Scale Layer command resizes the layer and its contents. ke image loses some of its 
quality by being scaled. ke command displays a dialog where you can set parameters 
concerning the size of the layer and the image quality.

You can access this command from the image menubar through Layer → Scale Layer.

4.6 Duplicating a Layer
ke Duplicate Layer command adds a new layer to the image which is identical copy of 
the active layer. ke name of the new layer is the same as the name of the original layer, 
but with “ copy” appended to it. 
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You can create a duplicate layer by clicking image menu→ Layer → Duplicate Layer, or 
from the local pop-up menu that you get by right-clicking on the Layer Dialog.

A Copy of your previous layer will be automatically made in the Layers tab.

5. MASKING
ke Mask is GIMP’s way of showing the full structure of the selection. Mask also provides 
the ability to interact with the selection in new, and substantially ways.Masking layers 
(similar to the fusion mask in Photoshop)which allows you to work on layers with great 
ease. With this method it is easy to edit corners without touching the layer. 

Step 1. Click the small outlined button at the lower lei of the image window to toggle 
Quickmask on and oh. ke button switches between Quickmask mode, and marching 
ant’s mode. 

You can also use Select → Toggle 
Quickmask, or Shii + Q, to toggle 
between Quickmask and marching 
ants mode. 

In Quickmask mode, the selection is 
shown as a translucent screen overlying-
the image, whose transparency at each 
pixel indicates the degree to which that 
pixel is selected. 

Layer Colors Tools Filte sr Windows HelpImageViewSelectEditFile

[nature] (imported)-3.0 (RGB color, 1 layer) 680×306 – GIMP

All

oneN

nvertI
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y ColorB

Fr m Patho

Selection Editor

Fea her...t

Sharpen

S rink...h

Grow...

Bo der...r

Distort...

Rounded R ctangle...e

Toggle uick MaskQ Shift+Q

Save to hannelC

To athP
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By default the mask is shown in red, but you can change this if another mask colour is 
more convenient. 

5.1 Editing a mask
To edit a mask, go to the channels tab, select “quickmask” channel, right-click to open the 
drop-down menu and selectEdit channel attributes…and change the colour.

Step 1:   Step 2:  

Set the settings and press OK

Step 3:     Step 4:  

Before Masking Before Masking
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A. MulƟple choice quesƟons
 1. _________ tool helps you to add a new layer to the image which is idenƟcal copy of the  

acƟve layer.
 (a) Smudge Tool   (b) Dodge Tool
 (c) PerspecƟve Tool   (d) Duplicate Layer

 2. By default the mask is shown in ______, but you can change this if another mask colour  
is more convenient. 

 (a) Red   (b) Blue
 (c) Green   (d) No colour

 3. In _________ mode, the selecƟon is shown as a translucent screen overlying -the image,  
whose transparency at each pixel indicates the degree to which that pixel is selected. 

 (a) Default   (b) Quickmask
 (c) Marching ants   (d) Normal

 4. __________ are the transparent sheets one on top of the other.
 (a) Masking   (b) Tools
 (c) Layers   (d) None of the above 

 5. By default the extension of Gimp Įle is ______
 (a) .XCf   (b) .BMP
 (c) .TIFF   (d) .PNG 

 6. GPL stands for 
 (a) General Private license (b) Great Pioneer License 
 (c) General Public Limited  (d) General Public License

 7. The image loses some of its quality by being _______
 (a) Scaled (b) Merging (c) Renaming (d) Masking

 8. _______ 
 (a) Adobe (b) Gimp (c) AŌer Eīects (d) Paint Shop Pro X5

 9. In _______ mode, over-applicaƟon of the tool will produce noise.
 (a) Sharpen (b) Blur (c) Dodge (d) Smudging

 10. ________ takes colour in passing and uses it to mix it to the next colours it meets.
 (a) Sharpen (b) Blur (c) Dodge (d) Smudging

B. Answer the following quesƟons:
 1. Name the applicaƟon areas where Gimp can be used.

 2. MenƟon all the features of Gimp.

 3. What do you understand by General Public License (GPL)?
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 4.  Which tool is used to align the objects placed on diīerent layers? Explain all its  
opƟons.

 5. Name the properƟes needs to be changed while scaling the image.

 6. Which tool is used to lighten the pixels in an image?

 7. Which tool is used to darken the colour pixels in an image?

 8. DiīerenƟate between Shear and PerspecƟve tool.

 9. What is the default background and foreground colour of image window?

 10. How is blur tool diīerent from smudge tool?

 11. Name any four tools used for changing the pixel arrangement in an image.

 12. What is the diīerence between Blur tool and Sharpen tool?

 13. How is Ňipping an image diīerent from rotaƟng an image?

 14. Write the steps to apply blend eīect on an image?

 15. What are Layers? What is the purpose of using Layers?

 16. What is the need of merging the Layers?

C. IdenƟfy the tools used for the following purpose:
 1. To resize the layer/image __________________

 2. To move layers __________________

 3. To align the layers with various objects __________________

 4. To create the mirror image  __________________

 5. To draw free hand drawings __________________

 6. To lighten the colour pixels of an image __________________

 7. To give wet paint eīect in an image __________________

 8. To shiŌ one part of an image/ a layer to a parƟcular direcƟon __________________

 9. To apply diīerent colours without eīecƟng the original image __________________

 10. To remove objects from the canvas __________________

D. ApplicaƟon Oriented QuesƟons
 1. Shivank has collected pictures of his favourite superhero and wants to make a collage of 

the superhero in acƟon. Suggest him the way to make collage.

 2. Amishi wants to change the background of her class photograph with the school \  building. 
Help her to do the same.
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 3. Rudraksh has to send his photograph to the passport oĸce for the processing of his 
Passport but his photograph clicked by the photographer is very dark due to insuĸcient   
light. Help him lighten the colour pixel of his photograph as per the requirement.

 4. Geetanjali has got a project work in she has been given two images, where one image 
depicts a girl walking on the grass and other one depicts an ocean. Now she has to 
project as if the girl is walking on the water surface. Suggest her the way to accomplish 
the task.

 5. Avni wants to change her coloured photograph into white/black photograph along with   
the borders and corners of the image without aīecƟng the original image. Help her to 
do the same. 

 6. Bhuvi is working on her social science project work. She wants to add the image of the  
Minister but the image is not in the required direcƟon. She needs the mirror image of 
the photograph. Suggest her the tool to perform the task.

 7. Mohit has got a hazy image. He wants to increase the contrast of the image. Suggest him  
the tool to complete the task. 

 8. Vasu has inserted an image in a new Įle. He wants to duplicate the image on the same 
layer. Suggest him the tool which will fulĮl his requirement.

�͘� >Ăď�^ĞƐ

 1. Collect the photographs of your family members and make a 
collage of the same. Design a Birthday card for your friend.

 (a) Add image of a Ňower and text to the card 
 (b) Fill the background with the texture format 

 2. Make abstract painƟng depicƟng 
Independence Day. Scan the image of 
any car and transform the image as 
shown below.

 3. Make a collage depicƟng the diīerent seasons such as Rainy, Summer, Autumn, Winter.  
Transform an image using perspecƟve tool.


